Problems with my AEKIIs...

Hi guys,

New to mechanical keyboards, but not to vintage things.

Have a bunch of old apple keyboards Im refurbishing/cleaning, and came across two Apple Extended IIs.

AEK 1: Works great! No indicator lights work. None flash. Nothing. Caps lock doesnt activate the caps lock light for example. Tried on my macintosh portable and my G3 (Just bought a USB-ADB adapter, cant try it on my modern PC)

AEK 2: Heres the weird one. Plug it in. Theres about a 50% chance it will work. When it works, it works great. Keys all work along with the mouse plugged in it. But, if I kind of slam it or tap it on the desk, strangely, the num lock light lights up and stays on, and I cannot type OR use the mouse! If I tap it again, the light goes off and I can use it again. Weird, right? Sometimes tapping it will result in all three LEDs lighting up very quickly.

I have looked AEK 2 over dismantled. There is no major damage that I can find. No corrosion. Looks perfect. Solder joints appear to be great, no broken ones. Maybe a loose chip or something? Im not familiar with keyboards and where I should start.

Could I please get some guidance? Id love to rescue both of these keyboards and get them fully up and running again... (Both are the better made in USA ones with the better ALPS!)

Edit

Took both apart and compared pcbs. Noticed two joints had long leads that were touching and trimmed them (The good one didnt have them touching). Put some more solder on the ground screws. Changed the issue litte. Plugging it in, no light on, cant type. If I just lift the thing up, the light goes on and wont go off (num lock). Tapping it makes the light flash, but stay on. If I push down in the bottom right area of the num pad (enter, +, 3 keys), the light goes off, but still cant type.
Johnnya101

Unread post29 Nov 2018, 02:09

X
Johnnya101
 
Posts: 3
Joined: 29 Nov 2018, 02:02
Location: United States
Main keyboard: Datadesk Mac 101E
Main mouse: Cheapo Dell
DT Pro Member: -
 
Sounds like broken traces on the PC board, possibly from getting dropped or stepped on. Visible cracks are the first clue, but traces can break and become intermittent even if the board itself isn't cracked. Get yourself a cheap ohmmeter or continuity tester and measure between the pads at each end of any trace in question, especially in the area where pushing on things makes it change. And try flexing the board gently while measuring any that seem to be acting funny. Often the traces will break right next to a solder pad, especially if the part attached to that pad got stressed.
Johnnya101 wrote:Hi guys,

New to mechanical keyboards, but not to vintage things.

Have a bunch of old apple keyboards Im refurbishing/cleaning, and came across two Apple Extended IIs.

AEK 1: Works great! No indicator lights work. None flash. Nothing. Caps lock doesnt activate the caps lock light for example. Tried on my macintosh portable and my G3 (Just bought a USB-ADB adapter, cant try it on my modern PC)

AEK 2: Heres the weird one. Plug it in. Theres about a 50% chance it will work. When it works, it works great. Keys all work along with the mouse plugged in it. But, if I kind of slam it or tap it on the desk, strangely, the num lock light lights up and stays on, and I cannot type OR use the mouse! If I tap it again, the light goes off and I can use it again. Weird, right? Sometimes tapping it will result in all three LEDs lighting up very quickly.

I have looked AEK 2 over dismantled. There is no major damage that I can find. No corrosion. Looks perfect. Solder joints appear to be great, no broken ones. Maybe a loose chip or something? Im not familiar with keyboards and where I should start.

Could I please get some guidance? Id love to rescue both of these keyboards and get them fully up and running again... (Both are the better made in USA ones with the better ALPS!)

Edit

Took both apart and compared pcbs. Noticed two joints had long leads that were touching and trimmed them (The good one didnt have them touching). Put some more solder on the ground screws. Changed the issue litte. Plugging it in, no light on, cant type. If I just lift the thing up, the light goes on and wont go off (num lock). Tapping it makes the light flash, but stay on. If I push down in the bottom right area of the num pad (enter, +, 3 keys), the light goes off, but still cant type.
Polecat

Unread post29 Nov 2018, 05:01

X
Polecat
 
Posts: 318
Joined: 14 Aug 2017, 05:04
Location: Bay Area CA
Main keyboard: Monterey K104
Main mouse: Logitech Optical
Favorite switch: Alps Blue
DT Pro Member: -
 
Will do. Any ideas on the lights not working on the good one?
Johnnya101

Unread post29 Nov 2018, 11:39

X
Johnnya101
 
Posts: 3
Joined: 29 Nov 2018, 02:02
Location: United States
Main keyboard: Datadesk Mac 101E
Main mouse: Cheapo Dell
DT Pro Member: -
 
Check electrolytic capacitors. Similar things happen with the Model M2
abrahamstechnology
User avatar

Unread post30 Nov 2018, 17:42

User avatar
X
abrahamstechnology
 
Posts: 447
Joined: 28 Jun 2018, 19:38
Location: United States
Main keyboard: G81-8000-LPDUS-2
Main mouse: Mitsumi ECM-S3902
Favorite switch: Buckling springs, White ALPS, Vintage Cherr
DT Pro Member: -
 
Small update...

Recieved my ADB USB adapter finally, and tested those two AEKs again.

AEK 1 works perfectly now! All lights work. Not sure what was going on before...?

AEK 2 still has those issues. Still have to find time to see whats going on.
Johnnya101

Unread post09 Dec 2018, 00:57

X
Johnnya101
 
Posts: 3
Joined: 29 Nov 2018, 02:02
Location: United States
Main keyboard: Datadesk Mac 101E
Main mouse: Cheapo Dell
DT Pro Member: -
 

Who is online

Users browsing this forum: Polecat and 64 guests

cron