Problem Report: Not getting email notifications

User avatar
thefarside

07 Jun 2022, 14:01

I’ve stopped getting email notifications. Is there a way to reset or fix that? Looking at my profile I don’t see any setting for turning on and off notifications.

Thanks!

User avatar
kbdfr
The Tiproman

07 Jun 2022, 16:00

User control panel > Board preferences > Edit notification options

User avatar
thefarside

07 Jun 2022, 17:48

Thanks I checked those settings and everything is enabled and has been since I created my account. Below is a screen shot.
BE3C3188-80A3-4777-BE1B-45A4E60EB4B1.png
BE3C3188-80A3-4777-BE1B-45A4E60EB4B1.png (504.85 KiB) Viewed 5710 times

User avatar
jsheradin

07 Jun 2022, 18:29

Try checking your spam folder. It's possible your email provider decided to start flagging them as spam.

User avatar
thefarside

07 Jun 2022, 21:53

jsheradin wrote:
07 Jun 2022, 18:29
Try checking your spam folder. It's possible your email provider decided to start flagging them as spam.
I’ve been checking that too and nothing from there. This has been happening for a while where I occasionally stop getting email notifications and I have to unsubscribe and resubscribe in the thread but that no longer works. Strange… :?:

User avatar
doomsday_device

07 Jun 2022, 22:19

same issue here :)

User avatar
thefarside

09 Jun 2022, 14:56

I fixed it! I don’t know which step resolved the issue but here’s what I did:
1) Went into my profile settings and unchecked all notification options and saved the changes.
2) Went into my profile settings and enabled all notification options and saved the changes.
3) Changed my profile email address to a different email - this worked and I started getting emails to the new address.
4) Changed my profile email address back to my original email.
5) Went into gmail and marked mech@deskthority.net as “Not Spam”.

I’m now getting emails again and hope this helps and works for anyone else with issues!

User avatar
thefarside

10 Jun 2022, 11:59

I spoke to soon. I got a registration email but still didn’t get any thread notification emails until I changed it back to my non-gmail email address. Is working now as long as I use my other email. I’m not sure why emails to gmail aren’t coming through as I’m not seeing anything in my spam or junk folders.

User avatar
doomsday_device

17 Jul 2022, 21:15

the issue still persists and it seems people with gmail account cant make accounts here anymore.

User avatar
thefarside

17 Jul 2022, 22:33

Sorry to hear that. Since my post I’ve switched to a non-Gmail account and things are working, but none of my attempts using Gmail have worked so far. Not sure why Gmail has a problem :?:

User avatar
doomsday_device

30 Aug 2022, 17:24

months later issue is still unfixed.

User avatar
Muirium
µ

30 Aug 2022, 23:15

Indeed. I don’t reliably get them either. Bugger all us mods can do about it, though. Like the headers carousel, this one’s in the sysop’s hands. While the tumbleweed blows…

User avatar
wobbled

30 Aug 2022, 23:40

Muirium wrote:
30 Aug 2022, 23:15
Indeed. I don’t reliably get them either. Bugger all us mods can do about it, though. Like the headers carousel, this one’s in the sysop’s hands. While the tumbleweed blows…
Do you guys have regular contact with our supreme overlord?

Ellipse

31 Aug 2022, 19:43

Someone seems to suggest a fix for the issue of emails not going through on their side; Deskthority IT admins need to fix something on their end - below is a copy of what was sent to me.

I had the same issue with gmail (no emails from DT went through, not even to to the junk folder) and had to switch my DT email to a non-gmail account.

"It looks like the
deskthority mails are slightly misconfigured at the moment, it's announcing
itself as "mech.deskthority.net" which isn't a resolvable DNS name:

warning: hostname mech.deskthority.net does not resolve to address
(IP redacted): Name or service not known
NOQUEUE: reject: RCPT from unknown[IP redacted]: 450 4.7.1
<mech.deskthority.net>: Helo command rejected: Host not found; from=<no-
reply@deskthority.net> to=<redacted@redacted.com> proto=ESMTP
helo=<mech.deskthority.net>

A lot of email servers will reject that by default, I can whitelist my end no
worries and that should sort the problem for me (done, aaand there we go
emails arrive) but should be an easy fix. Could explain why some mail services
don't get the emails through, now I'm activated I'll ping another email to the
admin."

apastuszak

31 Oct 2022, 17:52

I am not getting email notifications that my posts have replied. I checked my spam filter and there is nothing there.

User avatar
TheInverseKey

31 Oct 2022, 19:18

This has been a problem since Deskthority was sold and some email addresses including Gmail will never get emails.

engr

31 Oct 2022, 21:21

I was unable to register a Deskthority account using my Gmail address... the account activation email was never delivered. It was not in my spam box either. I ended up using my other email address.

User avatar
Muirium
µ

31 Oct 2022, 22:12

Merged topic. This ain’t getting fixed, folks. Needs admin love, not a lowly mod.

And honestly, convincing gmail your server is not spam is an ever tightening conundrum.

User avatar
TheInverseKey

31 Oct 2022, 22:14

Ne admin avail?
Image

User avatar
Muirium
µ

31 Oct 2022, 22:15

No. You new here? :lol:

apastuszak

01 Nov 2022, 02:19

I changed my email address. Let's see how that goes.

User avatar
Muirium
µ

01 Nov 2022, 08:18

I’m guessing to /google/dev/null or your provider of choice.

Big email providers really are ruining independent email servers for everyone, and therefore basic forum user account admin like ours. Thanks guys. Yeah, we’re not /r/dt? Who knew?

apastuszak

01 Nov 2022, 15:20

I switched to a simplelogin email address and now I am getting emails again.

Meowmaritus

01 Nov 2022, 17:18

site owner cant see us complain cuz he doesnt get email notifs KEKW

User avatar
Muirium
µ

01 Nov 2022, 19:43

I ran a quick* test: wrote Apastuszak a PM asking if they’d got an email notification when I did so. They wrote back confirming my hunch: DT’s server is still sending all these emails as requested.

*Would have been quicker if I’d gotten my damn email notification about my reply. But I use Gmail and Google’s pants are full of poopy.

User avatar
thefarside

02 Nov 2022, 01:39

I wonder if what ellipse wrote previously about the unresolvable host name mech.deskthority.net could be the issue?

felotus

21 Nov 2022, 22:35

Hi Guys,

I'm working on the IT at Admin's side and have access to DNS config (as well as full server). Is anyone still getting this issue? I added a new DNS record for mech.deskthority.net but it's unclear if it solved the issue as I cannot replicate the issue myself.

If anyone has any other tech issues feel free to shoot a PM, I'm just not online every day so don't get mad

User avatar
doomsday_device

24 Nov 2022, 11:54

still doesnt work (gmail)

pandrew

25 Nov 2022, 01:30

felotus wrote:
21 Nov 2022, 22:35
Hi Guys,

I'm working on the IT at Admin's side and have access to DNS config (as well as full server). Is anyone still getting this issue? I added a new DNS record for mech.deskthority.net but it's unclear if it solved the issue as I cannot replicate the issue myself.

If anyone has any other tech issues feel free to shoot a PM, I'm just not online every day so don't get mad
When sending email, for things to work properly, you usually need all of the following to be okay:
  1. The IP address you are sending from must have a reverse DNS. Doesn't matter what it is, it just must exist. If your ISP chooses it for you, it's okay (i.e. it doesn't necessarily have to do anything with the sending email address domain), but If you have control over choosing what it is, then that's even better, cause you can look even more trustworthy to email receivers. This is currently OKAY, points to mech.deskthority.net, See here. If you just changed it, then I see the current TTL is 24 hours, and if the previous TTL was the same, then it may take 24 hours for the changes to be visible for all nameservers.
  2. The domain name from the above step, must have an "A" record pointing back to the exact same IP. This is currently INCORRECT. See here, there is currently no A record for mech.deskthority.net
  3. The email-sending server must say the same domain name as discussed above in it's HELO line when it starts communicating with other machines. This appears to be OKAY, according to the last email I received. (Looking at the headers it says: "Received: from mech.deskthority.net ([159.69.68.22])", which looks correct!)
  4. SPF must not Hard-Fail, and it would be best if SPF didn't soft-fail. This is currently not quite right, at least 6 days ago when I received my last notification email, it wasn't.. My email client reports "SPF: SOFTFAIL with IP 159.69.68.22". Note that the SPF record must be set up correctly for the domain that you are sending the email from. The sender email is mech@deskthority.net, so the sending domain, is simply "deskthority.net" (not mech.deskthority.net), so looking up the SPF record for it: here, it points to zoho.eu, which in turn points to spf.zoho.eu, which, has the following IP ranges: here. The server you're sending mail from is not on the list. Please fix the SPF record, so it doesn't SoftFail, although, this is the lowest priority task on this list.
  5. DKIM must not fail!. This is currently INCORRECT.. On the message I received 6 days ago DKIM failed! Your email server (6 days ago) sends emails DKIM signed with the selector "s=mail;", but there is no DKIM signature published on the domain deskthority.net with the selector "mail", check here. Note again, that DKIM must be published on the domain of the email address you're sending from, so it must be published on deskthority.net, not on mech.deskthority.net.
  6. You should also check your email server, to make sure it's not on any blacklists, in case your ip has been used by spammers in the past, or in case some server misconfiguration allowed bots to send email from your server. This appears to be okay right now. See here
Prioritize fixing the things in RED, to get things working.

Post Reply

Return to “Deskthority talk”