DT Update Log and TODO

User avatar
kbdfr
The Tiproman

09 Jan 2019, 14:50

Spy function still not working correctly if tab simply stays open:
DT Forum_Spy_-_2019-01-09_14.41.16.jpg
DT Forum_Spy_-_2019-01-09_14.41.16.jpg (128.03 KiB) Viewed 822 times

User avatar
kbdfr
The Tiproman

09 Jan 2019, 14:53

By the way, I seem to get automatically logged out after a certain time when not actively browsing DT.

User avatar
matt3o
-[°_°]-

09 Jan 2019, 14:55

It must be a per user configuration because I only see absolute date/time. I'll check if I can fix that.

User avatar
kbdfr
The Tiproman

09 Jan 2019, 14:55

Oh, and matt3o no doubt deserves all the praise already expressed here.

Image

User avatar
Wodan
ISO Advocate

09 Jan 2019, 14:57

If there was a way to buy you a drink, let me know.

I know you're certainly not looking to make some pocket money here but there's gotta be a way to show some greatitude.

User avatar
kbdfr
The Tiproman

09 Jan 2019, 15:01

Wodan wrote:
09 Jan 2019, 14:57
If there was a way to buy you a drink, let me know.

I know you're certainly not looking to make some pocket money here but there's gotta be a way to show some greatitude.
+1



Spy’s weird behaviour:
DT Forum_Spy ;-).jpg
DT Forum_Spy ;-).jpg (116.79 KiB) Viewed 799 times

User avatar
matt3o
-[°_°]-

09 Jan 2019, 15:05

sorry, what is that is strange again?

User avatar
hansichen

09 Jan 2019, 15:14

The timestamps of the posts are posted correctly in my spy.

User avatar
webwit
Wild Duck

09 Jan 2019, 15:23

kbdfr wrote:
09 Jan 2019, 15:01
Spy’s weird behaviour:
Not weird really, the timestamps are server generated, so when there's a new post it's "less than a minute". The old spy then kept updating those relative timestamps in the client by javascript, the new spy does not. So it will accumulate "less than a minute" posts happily for an hour. It only shows updated time stamps on a page reload.

User avatar
matt3o
-[°_°]-

09 Jan 2019, 15:30

webwit wrote:
09 Jan 2019, 15:23
kbdfr wrote:
09 Jan 2019, 15:01
Spy’s weird behaviour:
Not weird really, the timestamps are server generated, so when there's a new post it's "less than a minute". The old spy then kept updating those relative timestamps in the client by javascript, the new spy does not. So it will accumulate "less than a minute" posts happily for an hour. It only shows updated time stamps on a page reload.
never noticed that, relative date/time must be a per user preference and I didn't even know you could change it.

This is how it looks to me.
Screenshot_20190109_152902.png
Screenshot_20190109_152902.png (57.94 KiB) Viewed 774 times
I'll see if I can switch to relative time and try to fix the spy.

User avatar
kbdfr
The Tiproman

09 Jan 2019, 15:56

matt3o wrote:
09 Jan 2019, 15:30
[…] never noticed that, relative date/time must be a per user preference and I didn't even know you could change it. […]
Exact:
DT 0001.png
DT 0001.png (259.23 KiB) Viewed 760 times
That’s a very minor issue though, other fixes are certainly more important :mrgreen:

User avatar
webwit
Wild Duck

09 Jan 2019, 16:31

I can still see your global settings, please donate money to DT and I won't share this most private data.

User avatar
Dingster

09 Jan 2019, 16:53

Personally prefered the old layout, due to everything being more "in one place", now it just seems staggered. Although I have to say that threads look much nicer now. :)

Findecanor

09 Jan 2019, 17:12

It feels a bit redundant to have the poster's name both above the post and to the right of it.

User avatar
Dingster

09 Jan 2019, 17:14

Also anyone have an unread PM they cant find?

User avatar
Muirium
µ

09 Jan 2019, 17:40

Check your Notifications settings. I was getting them for people quoting my posts, which had me sure I had new PMs for a bit until I figured it out and disabled the topic alerts.

Meanwhile, on every device I use (iPhone, iPad and Mac) to browse and post on DT, this is getting to be so common it’s a headache:
742111AD-9749-4348-8E10-C94933355ADF.jpeg
742111AD-9749-4348-8E10-C94933355ADF.jpeg (33.43 KiB) Viewed 693 times
I’m having to reload a lot, especially after hitting Submit, whether on WiFi or on cellular. I don’t get it. Only affecting DT, ever since the infrastructure upgrade last week, and more common now on the new site.
Last edited by Muirium on 09 Jan 2019, 17:44, edited 1 time in total.

User avatar
kbdfr
The Tiproman

09 Jan 2019, 17:41

webwit wrote:
09 Jan 2019, 16:31
I can still see your global settings, please donate money to DT and I won't share this most private data.
Image

Findecanor

09 Jan 2019, 17:44

Dingster wrote:
09 Jan 2019, 17:14
Also anyone have an unread PM they cant find?
I had a bunch, but I clicked "Mark all messages read".

User avatar
Dingster

09 Jan 2019, 17:54

Findecanor wrote:
09 Jan 2019, 17:44
Dingster wrote:
09 Jan 2019, 17:14
Also anyone have an unread PM they cant find?
I had a bunch, but I clicked "Mark all messages read".
Yea that worked, thank you

Slom

09 Jan 2019, 21:55

Thanks matt3o, it is way better on mobile now :) I can hit the spy button without zooming O_o

User avatar
Muirium
µ

09 Jan 2019, 22:36

I’m getting this about 50% of DT pageloads now.

Image

And yes, the same issue in Firefox. It’s an instant error. No loading has been done, just SMACK straight into ever the same unyielding wall.

Edit: trying 1.1.1.1 for DNS now. Seems better. Let’s see how it goes.

Edit: 2 minutes in and I hit the wall again. So nope. (And again while submitting this edit!)

User avatar
webwit
Wild Duck

09 Jan 2019, 22:52

If I search for that error it seems most likely that is a bug in your particular os version. Possibly it doesn't like the cipher protocol negotiated between server and browser.

User avatar
Muirium
µ

09 Jan 2019, 23:43

Two OSes though: iOS and Mac get it just as often as each other. And it’s intermittent, coming and going at random. Plus internet provider doesn’t seem to matter (I see it on cable and two different cellular networks) aaaand to round it off it’s just DT, since the underlying server software change. Kicked in last week or so.

User avatar
matt3o
-[°_°]-

10 Jan 2019, 00:07

unless I get more reports on that, I tend to believe that it's your problem (network, hardware or software).

we are indeed using very high quality encryption (SSL comes in a lot of flavors), well over the average, that might be a problem with some browsers, be sure to upgrade to the latest version (firefox should not have any issue). But honestly I don't think that's the issue.
dtssl.png
dtssl.png (10.66 KiB) Viewed 594 times
(we could do better than that... but I'd say let's not over do it)

I just ran a test and unless you have IE 8 / XP or Java 6u45 you should be good to go.

User avatar
zrrion

10 Jan 2019, 03:02

Will there be a way to switch which side avatars and whatnot are displayed on? It's my only issue with the redesign so far.

User avatar
kbdfr
The Tiproman

10 Jan 2019, 08:22

zrrion wrote:
10 Jan 2019, 03:02
Will there be a way to switch which side avatars and whatnot are displayed on? It's my only issue with the redesign so far.
Spoiler:
There already is (and always have been IIRC):
[deleted pic showing User Control Panel]
Edit: completely misunderstood the question, please disregard my stupid answer in the spoiler above.
Last edited by kbdfr on 10 Jan 2019, 15:32, edited 1 time in total.

User avatar
adhoc

10 Jan 2019, 14:16

webwit wrote:
09 Jan 2019, 16:31
I can still see your global settings, please donate money to DT and I won't share this most private data.
It’s a trap!

User avatar
Muirium
µ

10 Jan 2019, 15:05

@kbdfr:: I see no option there for *which side*. It’s surely a site layout issue.

User avatar
whocares

10 Jan 2019, 15:15

One thing which I do really miss are the images next to the threads inside the forum index, could you add those back?
I also noticed that the Youtube embeds were added back. I personally would prefer to see the old method of an image that gets replaced with an embed when opened. (Having the title there should be possible with phpBB, but I'm not sure.)

User avatar
Scarpia

10 Jan 2019, 16:42

This is looking better and sleeker every day!!

Post Reply

Return to “Deskthority talk”