Model M problem


26 Mar 2018, 16:52

'Pologies if this is in the wrong place, but I've done 2 bolt and screw mods on my model M's and have more to do, and with both I've had the same issue with the Pause/Break key.

In one mod I did a full replacement of the membrane sheets and in the 2nd I left the original, but on both, the Pause key seems to only register actuation half the time/intermittently, and doesn't repeat if held down.

I assume this is something to do with the tightness or lack thereof in that area of the board, but I've tried re tightening and loosening to no improvement. I'm wondering if anyone else has had a similar issue.


26 Mar 2018, 19:25

Did they do that before the mod as well? How are you testing that the switch works? Have you tried any other known working keyboards and see how your testing program responds to those?


26 Mar 2018, 22:23

I just got home and tried it out with the 5 other boards I have yet unmodded. They all do the same thing! How peculiar. The reason I believed it was an error on my part was that my current modern keyboard allows me to press and hold the pause button and it will repeat like all the other keys, but so far this isn't how the model m's seem to work!

I'll consider this resolved because thankfully my boards aren't faulty! But what an odd sort of 'bug' I hadn't read anything about before this.

TLDR - the pause key is working as intended - I thought it wasn't because on my modern compact layout keyboard it wasn't "pausing" as it should and it let me work the key in a way it shouldn't have


28 Mar 2018, 10:44

The Pause key doesn't autorepeat on a PS/2 keyboard.

Post Reply

Return to “Keyboards”