Page 1 of 1

Model F AT not working

Posted: 26 Nov 2018, 05:05
by Shifty
Hey all, I got an F AT off of ebay a few weeks back, but I've had no luck getting it going. The seller said it was working when he last used it, but that was over 6 months ago. I ordered a soarer's converter off ebay, but had no response from the keyboard when plugging it in, from looking at HID listen it seemed like the keyboard was not being detected. I forced set 2 on the soarer's but still no luck. Then I ordered an AT-PS2 converter and plugged that into my server. I haven't tried using it properly as I don't have a screen plugged into that machine, but I got no caps lock or scroll lock lights, even after a system reset with the keyboard plugged in.

So, any ideas? Any further tests I can do, or should I just bite the bullet and order an xwhatsit?

Re: Model F AT not working

Posted: 26 Nov 2018, 06:43
by SilenceGoo
Have you tried to disassemble and assemble it after some clean? Maybe the part connecting to the controller got some problem, try it.

Posted: 26 Nov 2018, 11:01
by Shifty
I've taken it apart completely, yes, couldn't see any obvious problems. I'm not too knowledgeable on electronics but I tested the keyboard's cable with a multimeter and couldn't see any problems there either.

Posted: 26 Nov 2018, 11:15
by Anakey
it would be helpful to take a picture of the controller board maybe there is a component that needs replacing and that is why it appears to be dead?

Re: Model F AT not working

Posted: 29 Nov 2018, 05:37
by cnrmsn
You can try replacing the electrolytic capacitors, they may have dried up or began to drift off value. It's a common thing for aging electronics.. If you can, send a picture of the PCB. Maybe it will help to diagnose the issue

Sent from my Pixel 2 using Tapatalk

Posted: 30 Nov 2018, 00:17
by Hypersphere
@Shifty: Which Soarer's converter and which At-PS/2 converter did you buy? I've had good results with Orihalcon's Soarer's converters and with the "Blue Cube" active converter along with an AT-PS/2 adapter.

Posted: 01 Dec 2018, 10:46
by Shifty
Thanks for the input guys! Here are some pictures, as I say, looks ok to me but I am no expert. The pcb is kinda warped as you can see in the last pic, but I don't think this would affect through-hole components much right?


Hypersphere, I got the soarer's converter from the seller tinkerboy on ebay, the AT-ps2 converter is just some generic one, I was under the impression you did not need an active converter for that conversion?

Posted: 01 Dec 2018, 17:17
by Hypersphere
I've never tried tinkerboy products. I have purchased many internal and external converters from Orihalcon, and they have always worked as intended. Regarding adapters/converters for "vintage" IBM keyboards, I have always used active converters, and they have always worked for me.

Posted: 04 Dec 2018, 01:50
by John Doe
Would you like take a photo for this part with more details, especially for the cables for connection? Once time, I got an f at with no luck working also, end up finding the different color cables messed.

Posted: 11 Dec 2018, 20:34
by JBert
Did you test it with the controller PCB disconnected from the inner assembly? (You shouldn't!)

There are supposed to be two screws holding it to the assembly and they serve as ground connections.