Looking for IBM Model M2 capacitor part numbers

User avatar

21 Aug 2019, 04:45


I'm looking for proper surface mount capacitor part numbers to replace those on an M2 that I could order from a distributor like Digikey or Mouser.

(Looked at the capacitor types article on Wikipedia - turns out there's a lot of them)

An upgrade recommendation that's not prone to leaking would be even better.



User avatar

21 Aug 2019, 11:39

The only value that should actually matter is their capacitance: usually measured in µF “micro farads”. Keyboards are nice and low voltage, so should handle anything you can find, just be the right capacitance.

I may be misremembering, but I think I heard modern electrolytic capacitors don’t leak any more, as the material was changed some years ago. But I could be wrong. Others may know more.

User avatar

21 Aug 2019, 23:31

Here's what the caps on my M2 controller look like (I don't know if there were different revisions of this controller):



C1 (16V 47μF) is about 6mm across and C3 (50V 2.2μF) is about 4mm. From the measurements I think the replacements in the same form factor would be:

https://www.digikey.com/product-detail/ ... -ND/766265

https://www.digikey.com/product-detail/ ... -ND/766298

But you don't need any particular kind of capacitor, as long as the voltage and capacitance match. I fixed up a board with these kinds

https://www.ebay.ca/itm/20pcs-pack-50v- ... 2336514713

https://www.ebay.ca/itm/16V-Electrolyti ... 2980624667

with the legs just bent and soldered parallel to the pcb. The ceramic one should be immune to swelling or drying up over time, but the replacement electrolytic one will probably last quite a long time too.

User avatar

24 Aug 2019, 03:46

Thanks for the links!

It seems that the controllers have been made by different OEM.

Your controller has slightly different silk screening compared to the controllers shown in this thread. Your main chip says Lexmark and Motorola while mine (now 2x) and j0d1's both have IBM and STMicro on them.

Y1 (what component is that?) is a different package but overall the traces look identical.


Last edited by Darkshado on 24 Aug 2019, 06:33, edited 1 time in total.

User avatar

24 Aug 2019, 05:12

I think Y1 is the clock crystal but it could be another capacitor (like those "Y capacitors" you find inside PC power supplies on the socket connector)


25 Sep 2020, 12:46


I'm trying to repair an M2 keypoard. The capacitors were changed 3 years ago. Anyway I've replaced them again but I can't take this keyboard back to life.

When I turn on the computer I can hear it beeping like if there was a key pressed and two leds are on. (the first and the second one)

The voltage out for the C3 is 4volts. I think is too little for a 50v capacitor...

I've tried with another PS2 keyboard and it works.

Is it possible that the Y1 component makes the keyboard fail? What the hell could be that component? Is seems it's connected between the second and the last pin of the main chip. Mine is like a little fuse is not the like the blue one you can see at the photos.

Sometimes messing up with the multimiter just testing the Y1 component the beeping stops, the lights turns off and then it starts agains after several seconds.

Anyone can help?

User avatar

25 Sep 2020, 16:40

swampangel wrote:
21 Aug 2019, 23:31
with the legs just bent and soldered parallel to the pcb.
Precisely what I do when repairing PS/2 floppy drives.


25 Sep 2020, 16:52

But Seriously,

Any ida about what is this component?
Captura de pantalla 2020-09-25 a las 16.51.25.png
Captura de pantalla 2020-09-25 a las 16.51.25.png (1.4 MiB) Viewed 980 times

User avatar

30 Jan 2021, 16:47

Hi all,

Has anyone figured out what that Y1 is?
I have successfully repaired two of these M2's but my third one needs something more than a recap.
The board looks fine but Y1 is corroded.


30 Jan 2021, 19:32

That Y1 connects to the crystal oscillator pins of the microcontroller,
so it's probably just a crystal in an unusual package.
4.00 writing on it suggests that it's probably 4MHz.

User avatar

30 Jan 2021, 23:27

Thank bro, that's useful
How did you figure out it's the crystal oscillator pins? I tried to find the data sheet for the IC but couldn't find it.
You have it? Please share :)
I thought I'd try to swap it with one from my working boards to test it. but those bastards have three pins.
I guess i'll bring out the scope


31 Jan 2021, 03:36

Here's the datasheet of the chip used in the M2, called EF6805U3:
https://www.digchip.com/datasheets/down ... r=EF6805U3

Unfortunately it only has the DIP package pinout, and not the PLCC one.
However, in order to guess at what is the correct PLCC pinout, let's look at a different chip in the same family that, also has a 40-pin dip variant and a 44-pin PLCC variant:

Here you can compare the DIP and PLCC packages.
You will notice that all the pins that have a functionality are in the same order when you compare DIP and PLCC packages of the same chip. This makes sense, they most likely use the same silicon die on the two chip variants, and the insides look something like this:
bond_wires.jpeg (6.78 KiB) Viewed 498 times
And while you could skip some extra pins, you really don't want to cross bond wires.

So it's a good assumption that useful pins will be in the same order on the EF6805U3 PLCC package, as in the EF6805U3 dip package. Except there will be 4 more NC (Non-connected) pins. The EF6805U3 DIP package already has an N.C. pin, so we expect to have 5 NC pins total.
We already know which is pin 1, since it's marked with a dimple.
I start by putting the multimeter into continuity mode, and beeping out from gnd (the negative side of the big cap), to any pins on the chip. I have pins "1" and pin "23" beep. Pin 1 makes perfect sense, since pin 1 on the DIP also is VSS, so all okay so far. Pin 23 looks like it has a thick ground trace connected to it, and it looks intentional (i.e. it's not just thick because of an accidental ground fill), so it must be a real ground. I suppose when going from DIP to PLCC, they could have easily added ground as well instead of NC pins. So I take a note that pin 23 is Vss, and that I'm only looking for 4 more NC pins now.

I continue by beeping from Vcc (the positive side of the big cap) to any pins, and I find that pin 4 beeps. Pin 4 on the DIP package is also Vcc, it all makes sense. So therefore it must be true that pins 2 and 3 are also the same as on the DIP package, so pin 2 is ~RESET and pin 3 is ~INT.
You might notice that pin 2 (~RESET) is connected to the smaller cap's positive side. This is because the smaller cap is used as a circuit to delay the de-assertion of the microcontroller reset until the power supplies have stabilized, and the clock is running stable. In fact, in my experience this smaller cap is the one that is causing more trouble. If this cap dies then the microcontroller won't get reset properly on power-on. You can test this theory, by just quickly shorting the pins of the smaller capacitor. This will temporarly fix a misbehaving M2, until the next power cycle of the keyboard.

Now let's look for any NC pins: N.C. could be two things:
1) It could be a pin, that is connected internally to the die, and it has a function, but the function is hidden from the user. (It could be test mode functionality only used in the factory, or it could be a feature, that has been undocumented, because it didn't work right), No matter what the reason is, the expectation is that the user will leave pins as such floating.
2) True-NC pin that are actually not connected internally in the chip.

You can measure out true-NC pins, because all internally connected pins will have an ESD diode pointed from ground to the pin. So you can measure internally connected pins by putting the multimeter into diode mode, and touching the red wire to Gnd/Vss, and the black wire to the pin. If it shows a value that is not infinite, or not out-of-range, then it is a pin with some functionality. If it's not measuring anything then it's a True-NC pin.
Doing this measurement I found the following True-NC pins: 6, 20, 40.
But we were looking for 4, so it must be that we have one more non-true-NC pin.
Since this is not a true NC pin, this pin is most likely to be in the same position as on the DIP package, so right after the XTAL pin. I think this is a good assumption, but double-checking, I also tried to beep out any connections I could find between pin 8 in the PLCC package and anything else on the board, but I didn't find anything, so I think we're good.

With all of this in mind I think we're ready the draw a best-guess pinout, and it's:
m2_controller_guessed_chip_pintout.png (67.17 KiB) Viewed 498 times
You will see that the white two-terminal device will connect to the XTAL and EXTAL pins.
but those bastards have three pins
The middle one of those 3 pins is probably just ground:
crystal_with_ground.png (89.27 KiB) Viewed 493 times
Last edited by pandrew on 21 Feb 2021, 19:15, edited 1 time in total.

User avatar

31 Jan 2021, 09:36

Great post, thanks

I didn't think to check all my IC's. One has the Lexmark/Motorola 1395980 but my bad board has the ST/IBM branded EF6805U3.
I checked with the scope and it sure looks to be a crystal.
However, on my bad board the crystal just goes high (1,1v) I went ahead and ordered some two pin crystals and will report back when I get it.
I also tried the reset trick mentioned above (shorting the small cap) but it doesn't help.


31 Jan 2021, 10:19

I didn't think to check all my IC's. One has the Lexmark/Motorola 1395980 but my bad board has the ST/IBM branded EF6805U3.
I thought all M2 PCBs were the same.. Can you post a picture of this one that's different? Also a picture of the board with the 3-pin crystals?
The 1395980 sounds like a client-part-number
The EF6805U3 is a mask-rom chip, so not user-programmable. IBM/Lexmark send in the ROM image, and ST make for them a custom variant of the chip where all they do is replace the ROM. So the resulting chip will also be branded with the client's name / part number.
My chip has:
m2chip.png (79.61 KiB) Viewed 448 times
See it also has an '139' type marking.
Maybe they just removed the original part number from later iteration markings, and it's essentially the same?
I checked with the scope and it sure looks to be a crystal.
Is it 4MHz?
However, on my bad board the crystal just goes high (1,1v) I went ahead and ordered some two pin crystals and will report back when I get it.
I also tried the reset trick mentioned above (shorting the small cap) but it doesn't help.
Can you send a pic of your dead controller?
I repaired an M5-2 trackball controller, which had the exact same problem as the M2s do, and it's using the same style of capacitor, on what I presume again is a reset line. However it was much worse, the capacitor has leaked it's electrolyte, leaving corrosion, and eating up some traces. I ended up having to add two jumper wires for it to work, after cleaning up all the corrosion (so it doesn't spread).

See some pictures of the M5-2 repair, expand the spoilers here:
Green (on the right-most pin) is always a bad sign:
m52_pic1.png (687.05 KiB) Viewed 448 times
Next picture: Capacitor removed. The bottom pad itself was the worst, (this is the other pin that wasn't even green) while the problem was visible before taking off the cap, I had to keep cleaning it with a soldering iron a lot, it had a lot of gunk on it. You can see the bottom trace that is broken. However when I took this second picture, I didn't realize that the top trace was broken too. I only found it after adding the bottom jumper wire wasn't enough to make it work, so I started debugging. Do you see the dark dimple in the top trace?
m52_pic2.png (344.2 KiB) Viewed 448 times
Fixed with two jumper wires.
m52_pic3.png (691.9 KiB) Viewed 448 times
So I suggest you should beep out with a multimeter any traces that are in corroded areas, even if the traces themselves don't necessarily look corroded. It could be not the component, but the traces that connect them.
And double-check that you have about 5V between Vcc and Vss pins of the microcontroller, and that the ~RESET pin is high ( about 5V. 1.1V on the reset line would not be enough. Crystal is a different story, could have a special driver. For the crystal you should only make sure that there's continuity between chip pins and crystal pins)

No matter what you do make sure that you clean up any corrosion that you see. Replace all corroded solder joints, and clean up the board after with alcohol, or it might spread.

User avatar

04 Feb 2021, 19:45

I didn't get a notification when you posted and missed your last post. I need to check my forum settings.
I have put my M2's away while I wait for for the new crystals to make room for other projects. I'm actually writing this post on a 1987 Model M on my modern iMac :)
I will bring the M2's out in a few days again and post pictures.

User avatar

21 Feb 2021, 18:27

I managed to fix my M2!
It was the corroded crystal that caused my board to fail.
I tried to replace it with a generic 4Mhz SMD crystal but it was to wide for the board.
I could have bodged it but ended up using a though hole crystal standing on top of the board with bent legs instead.

Hope this is helpful for anyone passing through here with the same problem.

PS. The caps are still the most common problem with the M2.
Replace the caps first. In this case the electrolyte from the leaky caps probably killed my original crystal.


Post Reply

Return to “Keyboards”