Issue with Numpad = on ADB to USB converter

User avatar

26 Jun 2020, 05:45

Today I finally got around to putting together an abd to usb converter. Everything seems to work except for the numpad equals. in EK switch hitter when I press the numpad equals I see no scan codes. If I press nupad equals wiht the cursor in the windows search bar a '5' character appears. But if I press numpad equals almost anywhere else it does nothing. Could this be beacause of the layout that I used? I double checked, and even reflashed the pro micro that I used and it still does the same thing.

This is the layout that I used. The only thing that I changed was I made the ' ` ' key into the regular grave accent (the key to the left of the alpha block's '1').

The converter also does not differentiate between the left and right command key, but I understand that this is a limitation of ym AEK not the converter.

Does anyone know how to fix this? If I have to I can always make it sent the scancode of the regular equals, but I'd rather have them be differentiable.

User avatar

26 Jun 2020, 05:55

I just tried it with an M0487 and an M2980 and they both behaved the same way.


26 Jun 2020, 06:29

MS-Windows does officially not recognise USB's Numpad = code, but MacOS does.

Microsoft's own Natural Keyboard 4000 sends the standard code for it but on another interface, and it is recognised by a special driver. Without that driver, the keyboard's key does nothing in Windows, but is recognised on other OS'es. I dunno about other MS keyboards.
Edit: I have also tried with a Apple Aluminium keyboard, which sends the key in the normal keyboard report.

User avatar

26 Jun 2020, 22:29

I just tried it on a Mac and you are right. Thank you. I will just reflash it to have the regular equals there then.

Post Reply

Return to “Keyboards”