1993 IBM model m sending double key presses

User avatar

06 Apr 2021, 17:48

Hi everyone I recently got a model M that had a bad membrane and was able to screw mod it and replace it. Overall I am happy with it, but I have had a strange issue, occasionally I will get a double keypress when pressing the key once. For example if I am trying to type “v” the computer will receive “vv”

I first had the problem with the V key, and after taking the board apparat and replacing the spring and flipper assembly the problem appeared to go away. However it has not resurfaced with the R key. I don’t mind taking it apart again, but I was wondering what could be causing this so that I could try to avoid it when assembling it this time.

Keyboard pic:


06 Apr 2021, 18:23

For some reason I have a similar issue with my first-attempt screw-mod. This board sends - continuously on starting up the computer up until I press the - key (does not matter which key, the key on the numpad or the one next to right shift). After that everything works like it should. First I thought a slightly misaligned membrane could be the reason but I doubt it is.
Last edited by feltel on 06 Apr 2021, 18:51, edited 1 time in total.

User avatar

06 Apr 2021, 18:43

Try pull out the spring and reseat (doesn't require full disassembly as you can use something like a toothpick)


06 Apr 2021, 20:14

This can be quite easily fixed at the operating system level.

Windows: (I believe from XP to latest 10) using an HKCU "Keyboard Response", "Bounce Time" registry hack. I prefer 22ms value here.
Linux: (Mint/Cinnamon) in Accessiblity Settings - there's a slider for this setting (something almost left seems to be the right value).
Mac: Dunno. But there must be a similar setting.

User avatar

06 Apr 2021, 21:37

Bear in mind you’re telling your computer to sit around and wait on all incoming keystrokes, from all keyboards, just to make sure they don’t bounce. I wouldn’t advise doing this if you type fast, let alone game!

I believe there is no way to do this on Mac (not even in Karabiner to my knowledge) and I’m surely not looking for one. :lol:


06 Apr 2021, 22:20

Maybe you need more than 45 key downs and ups of the same key in one second while gaming. Maybe there are gamers with such a fast finger. While fast touch typing you possibly might have problems with words like (account, bliss, cell... etc.) but 22ms seem to be fast enough. I'm a touch typist and this is my fine tuned value. Other people (or keyboards) may need different values.

Btw. don't keyboard controllers filter bouncing as well? Couldn't be the OP's problem also here...?

I've exported this registry setting from my work laptop:
[HKEY_CURRENT_USER\Control Panel\Accessibility\Keyboard Response]
"Last BounceKey Setting"=dword:000001f4
"Last Valid Delay"=dword:00000000
"Last Valid Repeat"=dword:00000000
"Last Valid Wait"=dword:000003e8

User avatar

06 Apr 2021, 23:56

I wouldn't mess with software / registry hacks before attempting to fix it at a hardware level. Every time I've had double key inputs from a Model M I've fixed it by reseating the spring and/or key stems.

User avatar

07 Apr 2021, 01:10

Ideally I would like to fix it on the hardware level. The converter I am using is this one could that be part of the issue?

https://www.amazon.com/gp/aw/d/B00IACID ... asin_title

I will take the board home tonight and try to reseat the spring and keycap. Could it be something to do with the tension of the screws?

User avatar

07 Apr 2021, 10:13

Most definitely a suspect in this inquiry!

Haven’t got a native PS/2 machine to test it with? Another option, which would make the keyboard fully programmable, is one of Orihalcon’s ready made Soarer’s converters.

User avatar

08 Apr 2021, 18:06

I've seen this on a few bolt or screw modded M's. Try backing off the screw tension around that key. The screws hold tighter than the plastic rivets and it's real easy to over tighten them. Next thing I'd look at is make sure no schmoo from the bolt modding process got in between the sheets of the new membrane too.

You might have also gotten a dud replacement membrane.

User avatar

13 Apr 2021, 17:20

Hi Everyone,

I just wanted to give an update for anyone who finds this thread in the future. I tried reseating the spring and cap, and it seems to have fixed the issue. It’s now been a week of typing and so far no repeats.

I do not believe that the converter was the issue here, as it appeared to only be one key rather than constant across the board.

Thanks to everyone for the help! I really appreciate it, and I’m looking forward to using my bold modded model m for many years to come.

Post Reply

Return to “Keyboards”