New to Deskthority, need help


12 Jun 2021, 07:47

Hello everybody,

I'm not sure if this is the rigth place to ask, please feel free to tell me so. I'm new to Deskthority.

I have always been a fan of old keyboards, but where I live there is not much of a chance to see one.

Yet a few years ago, I was passing over an old bazaar store when I noticed a really old keyboard (I'll upload photos for you to see).

When I felt the clickly switches, I knew I just had to buy it!

It's an NTC Model KB-6251EA. Very heavy as it has a metal plate on top of the circuit board and it says "Zeos performance". It has white alps switches.

Unfortunatelly, it does not work. Or rather, it is glitchy. It registers "p" repeatedly as well as other numbers depending on what I press. So I left it for years in the closet untill I finaly decided today to do something about it.

I took it to an electronics expert and he told me after analysing it that it was the CPU chip (or whatever it is called).

The CPU reads as follows;

"Intel P8749H
21V Program
Intel (m) (c) 1980"

It has 40 pins and it was quite easy to slot off the board.

I've checked on ebay and there are a few "Intel P8749H" for sale. They are all 40 pins and look exactly like the chip on the keyboard.

But what worries me is that the second line (starting with L) is always diferent. By L line I mean;

"Intel P8749H
21V Program
Intel (m) (c) 1980"

I'm no electronics expert. I would like anyone who knows about these things to please help me. I was just wondering whether that "L" number is just a serial number. That is, if I was to buy such a chip would it work?

Please check the images. Sorry if I waffle on, and I hope I am not too confusing. I would really apreciate your help and advice.

Kind regards,


My keyboard with the cover on.jpg
My keyboard with the cover on.jpg (1.69 MiB) Viewed 1380 times
IMG_20190902_190042.jpg (176.88 KiB) Viewed 1380 times
IMG_20210611_194409.jpg (3.79 MiB) Viewed 1380 times
IMG_20210611_230045.jpg (3.64 MiB) Viewed 1380 times
IMG_20210611_231906.jpg (2.88 MiB) Viewed 1380 times
What I found on ebay.JPG
What I found on ebay.JPG (57.39 KiB) Viewed 1380 times
Yet another one I found on ebay.JPG
Yet another one I found on ebay.JPG (80.82 KiB) Viewed 1380 times

John Doe

12 Jun 2021, 08:26

I highly doubt that'll work.

The chips are programable so only if you have flashed matchable firmware it could be saved with the original like controller, seems that's impossible to get the original firmware. But apparently there're other ways to make it to hook up to modern pc.

I'm definitely no expert tho, just my very personal understanding. Glad to see others chip in.


12 Jun 2021, 20:36

Thanks for your advice!

Sounds like we would have to find another option, if there is one.


12 Jun 2021, 22:39

Could just be that your "P" switch is permanently on, so you could desolder that and if the "p" stops being output, the rest of it might work as well. It's fairly unusual for ICs to be bad, though you might look for bad capacitors though if there are any.


12 Jun 2021, 23:41

That's what I thought too! But sometimes it registers other characters from the start. And besides, the electronics expert told me all the switches work fine as well capacitors and resistors and what have you. Thanks a lot anyway!


12 Jun 2021, 23:44

But he could be wrong I suppose. But I would not know where to start checking. :(


18 Jun 2021, 20:05

Did you already tried to switch the protocol? According to the wiki there should be an XT/AT switch, located next to one of the flip-out feet. (Sorry for the clumsy advice)


20 Jun 2021, 01:31

Hi Hausen,

Great idea! The switch reads, "80206/8088". I'm not sure which one of these numbers represents AT or XT but I've tried both.

"8088" produces those weird repetive signals I've mentioned before, however, whenever I click caps lock, num lock, and screen lock the respective LEDs light up on the board. By they way, the setting was originally "8088" when I bought it.

"80206" produces no response at all, and when I click all the caps, num, scrn lk nothing lights up. It's as if the keyboard is completely dead on that setting.

I forgot to say that I bought this cheap USB converter, since I don't have a PS2 port on my laptop (I'll upload an image). I've tried this converter with other ps2 keyboards to make sure IT was not the problem and it works fine.

Wondering maybe it does not work with THIS particular keyboard?

I'm going to take this keyboard to another electonics expert to get a second oppinion and will let you all know.

Thanks anyway for your help!

It's even the same color.JPG
It's even the same color.JPG (21.22 KiB) Viewed 945 times

User avatar

20 Jun 2021, 01:50

Crimsonpizza wrote:
20 Jun 2021, 01:31
Great idea! The switch reads, "80206/8088". I'm not sure which one of these numbers represents AT or XT but I've tried both.
The 8088 and 80206 are the Intel processors used in the original IBM Personal Computer (which used the protocol now often referred to as "XT", scancode set 1) and the later IBM PC AT (set 2) respectively. I have this one two of my keyboards as well; it's just a protocol switch. The one you most likely want is 80206 unless you're using it with a really really old PC.


24 Jun 2021, 23:42

Thanks for that! The currect setting is "8088". I'm sure the other setting (80206) gave me no response whatsoever. I'll check it again tho and let you a'll know.

User avatar

05 Jul 2021, 17:00

Take whatever I say with a grain of salt and someone please correct me if I'm wrong, but:

According to the wiki, an AT keyboard (the 80206 setting on your switch) should work with a PS/2 host with just a passive adapter, which you already seem to have.

Then the PS/2 can be converted to USB with a converter. The PS/2 to USB adapter you have, may be just an adapter, instead of an active converter, hence the reason why it's not working.

You can try to get an active PS/2 to USB converter and try it that way on the 80206 setting, or you can just get an XT AT to USB Soarer's converter from orihalcon over at eBay:

It allows remapping and what not.

With the converter I linked, the keyboard should in theory work regardless of the switch's position. If it doesn't work properly with Soarer's converter or the keyboard keeps spamming a key, then for sure there is something wrong in the keyboard somewhere.


17 Jul 2021, 06:22

Sorry guys for the long wait, I have been very busy with other stuff.

With regards to the 80206/8088 switch.

As you know it was in "8088". I switched it to "80206" and... it sort of responded. I had notepad open and in it I got "111111..." but when I clicked backspace, and it actually deleted the 1's. Then I typed "h" and it gave me repeating "hhhhhhh....." then I typed "o" and got repeated "ooooo...." then I typed something else and... nothing, it stopped responding.

Then, I tried connecting and disconnecting the keyboard several times, clicking buttons here and there but I never got the same response. Rather, the computer went crazy every time. Opening windows and highlighting random icons in desktop. So I restarted the laptop.




17 Jul 2021, 06:34

Hi ifohancroft,

It might be an idea to get another converter. The problem is getting one here in Mexico, it's a bit of a hassle, not to mention expensive. At $40 US ($800 pesos) it seems more trouble than the keyboard's worth (I bougth it for 80 pesos by the way).

Just to give you an idea. 2 weeks ago I bought a refurbished Corsair K95 Vengeance (Cherry MX reds), for $500 pesos. So far, it works like a charm.

I'll have to check the local market tho, I might be lucky to find a soarer converter.

Thank you for your help, I really appreciate all the input.

I'll keep you all posted of any eventualities.



User avatar

17 Jul 2021, 06:35

Sounds like the controller is working, or trying to. Looking at the closeup photo it's disturbing to me how dirty the PC board is. It's possible that all the crud around the components is causing erratic behavior. Seems like a good cleaning might be in order.


18 Jul 2021, 02:36

Hi Polecat,

True, it's pretty dirty. I was planning to do it after I got the keyboard working. But it may be the reason why it's not working. Won’t hurt to give it a clean, eh? I guess it’s time to whip these out!


001.jpeg (245.67 KiB) Viewed 314 times

User avatar

18 Jul 2021, 05:19

Uh, the solution (pun intended) for this does not come in a spray can.

edit: I'm serious about this, you probably don't want any spray cleaner getting inside the switches, and certainly not the crud that gets washed off the PC board along with the cleaner. The right way is to unsolder the switches, separate the plate and PC board to get access to the whole thing, and carefully clean everything before reassembling. Yes, it's a lot more work, but that's the right way to do it.

User avatar
dye hard

18 Jul 2021, 12:38

ifohancroft wrote:
05 Jul 2021, 17:00

Then the PS/2 can be converted to USB with a converter. The PS/2 to USB adapter you have, may be just an adapter, instead of an active converter, hence the reason why it's not working.
Just contributing to this with my (limited) experience.

I have a couple of those same PS/2 to USB adapters, they are active and they are quite solid for the price. I have used them in plenty of Dell, Model M and other vintage boards, it's my favourite cheap kb adapter.

Unless Crimsonpizza has been very unlucky getting a defective one, that adapter should not be the problem.

Post Reply

Return to “Deskthority wiki talk”