Mass renaming of pages

User avatar

18 Jan 2018, 01:38

Mostly for Daniel and other admins, as regular users cannot use Special:ReplaceText

I haven't tried myself but theoretically one *can* mass rename pages using this extension. The recent "Trantek KS4 *" to "TTC KS4 *" change would involve specifying something like

Code: Select all

Original text: .* KS4 .*
Replacement text: TTC KS4 $2

Use regular expressions: checked
Replace text in page titles whenever possible: checked least if I'm understanding correctly the regexp syntax. In the form you get upon clicking "Continue" you can enable/disable redirections being created automatically pointing to the new pages.

I suggest giving that a try instead of blaming the software in the logs.

User avatar
Daniel Beardsmore

18 Jan 2018, 09:41

Page rename is broken. On image pages, it will split the image apart from its description (!!) and when I tried to rename the Trantek redirect pages, nothing happened. I know how to use it, but it doesn't work.

User avatar
Offtopicthority Instigator

18 Jan 2018, 09:46

Is that the reason for something peculiar like this?
(Move log); 08:37 . . Daniel beardsmore (Talk | contribs) moved page NEC H0150-STD1-01-17 to NCR H0150-STD1-01-17 without leaving a redirect ‎(Oops)

User avatar

18 Jan 2018, 10:55

OK, I'll try to test this is on a more recent version of the software and then report back.

Update: I can confirm that mass renaming of pages within the main namespace works with MW 1.29.0 and ReplaceText 1.2 (Apr 9, 2017, rev b02d10f), so this is a problem that only @webwit can solve.

User avatar
Wild Duck

18 Jan 2018, 13:02

Not sure what went wrong, I used this extension a lot in the past with no problems.

User avatar
Daniel Beardsmore

18 Jan 2018, 19:27

seebart wrote: Is that the reason for something peculiar like this?
What was peculiar about that correction? The page name was wrong.

Page renaming has been defective in the Deskthority wiki for years. Content replacement is fine, but page rename requests generally get ignored. The only time it seemed to do anything was when I renamed a load of images a couple of years ago, and the File: pages were renamed but not the images themselves, so the images no longer loaded. I think I had to manually rename each File: page back to its old name, and then manually rename it to its new name to "couple up" the images back to their respective File: pages.

Post Reply

Return to “Deskthority wiki talk”