Zenith Z-150 "Beige Label" Build Help

User avatar

27 Oct 2021, 21:02

That was interesting. I started with the F keys and I had no problem. Tried the top numeric row and each key registered twice. Tried the letters and number pad. No problems. Tried the top numeric row again and it worked.

I'll see if I can duplicate that with hid_listen ... listening.
Last edited by hellothere on 27 Oct 2021, 21:06, edited 1 time in total.

User avatar

27 Oct 2021, 21:06

Still working.

Code: Select all

Waiting for device:............


USB configured.

Loop start.
395 PRT:11 ISR:6A90 rAA A3312 wFF rFA rAA W3551 R4052
ID:FFFD(AT_Z150) S4052 wED rFA w00 rFA L4058 r05 rF0 r05 r06 rF0 r06 r04 rF0 r04 r0C rF0 r0C r03 rF0 r03 r0B rF0 r0B r02 rF0 r02 r0A rF0 r0A r01 rF0 r01 r09 rF0 r09 r76 rF0 r76 r16 rF0 r16 r1E rF0 r1E r26 rF0 r26 r25 rF0 r25 r2E rF0 r2E r36 rF0 r36 r3D rF0 r3D r3E rF0 r3E r46 rF0 r46 r45 rF0 r45 r4E rF0 r4E r55 rF0 r55 r66 rF0 r66 r0D rF0 r0D r15 rF0 r15 r1D rF0 r1D r24 rF0 r24 r2D rF0 r2D r2C rF0 r2C r35 rF0 r35 r35 rF0 r35 r3C rF0 r3C r43 rF0 r43 r44 rF0 r44 r4D rF0 r4D r54 rF0 r54 r5B rF0 r5B r14 rF0 r14 r1C rF0 r1C r1B rF0 r1B r23 rF0 r23 r2B rF0 r2B r34 rF0 r34 r33 rF0 r33 r3B rF0 r3B r42 rF0 r42 r4B rF0 r4B r4C rF0 r4C r52 rF0 r52 r5A rF0 r5A r12 rF0 r12 r1A rF0 r1A r22 rF0 r22 r21 rF0 r21 r2A rF0 r2A r32 rF0 r32 r31 rF0 r31 r3A rF0 r3A r41 rF0 r41 r49 rF0 r49 r4A rF0 r4A r59 rF0 r59 r5D rF0 r5D r11 rF0 r11 r0E rF0 r0E r29 rF0 r29 r58 wED rFA w04 rFA rF0 r58 r70 rF0 r70 r71 rF0 r71 r79 rF0 r79 r7B rF0 r7B r7C rF0 r7C r7F rF0 r7F r7E wED rFA w05 rFA rF0 r7E r77 wED rFA w07 rFA rF0 r77 r6C rF0 r6C r75 rF0 r75 r7D rF0 r7D r6B rF0 r6B r73 rF0 r73 r74 rF0 r74 r69 rF0 r69 r72 rF0 r72 r7A rF0 r7A

User avatar

28 Oct 2021, 05:32

Thank you for your test. The debug log looks ok now.

I updated firmware. No big change for Z-150 AT, though.
You can download new firmware on Keymap Editor now.
https://geekhack.org/index.php?topic=10 ... msg3090743

Let me know if you have any problem with new firmware.

Alps or any switches can have chattering, you need to clean?

User avatar

28 Oct 2021, 19:27

They're cleaned and lubed. Maybe I accidentally knocked one of the wires on the converter. Maybe the Zenith just needs a little time to warm up. It is pretty old :D.

User avatar

07 Nov 2021, 11:03

Looks like I decided to purchase a Z-150 at the right time! Great to see the process here. Unfortunately, I still still haven't been able to get stuck into mine yet but I'm hoping to find some time this month.

So, how are you finding? And what cleaning/lubing method did you choose?

User avatar

07 Nov 2021, 20:14

This is a general process for me and Alps:

* Mounting plate:
If the mounting plate is rusty, I do desolder all the keys, sand down or use Evaporust, then paint the mounting plate with rust-proof paint, like Rust-Oleum. I had to do this on my Z-150. If yours is just dirty, a big paintbrush and/or a dish scrubber with bristles works great. Obviously, don't fill it up with soapy water. You can also get the cheapest possible versions.
* Cleaning switches:
** For both sliders and top housing, I use an ultrasonic with either Simple Green + water or denture tablets + water. I'll recommend using distilled water, if you have access to that. I do this for 30 minutes or so, stirring every time I have to get up and hit the timer on my ultrasonic. I also use as hot water as I can in my ultrasonic, which is around 50 C / 122 F / 322 K / 581 R.
** I use compressed air to blow out the bottom housings.
* Lubing switches:
** I use a ceramic-based wet lube (hey, I didn't know it had paraffin in it), both on the sliders and top housing slider rails, using a small paintbrush to apply it. Note that there's a rather long thread saying that straight paraffin + hot water will work for your sliders. In either case, you don't need much.

While I don't recommend removing the bottom switch housing unless you do have a rusty mounting plate, I have an 1984ish keyboard with blue Alps. I started removing the top housings and 1 of 3 of the retaining clips for the bottom housing snapped. I've removed top housing hundreds of times and I rarely break one, so I'm just going to desolder them and use orihalcon's switch opener. I don't have a ton of blue Alps parts.

User avatar

18 Nov 2021, 20:34

Project status: I've built another Hasu and I have it in the keyboard case, with a mini-usb to USB A extension hanging outside of the case. I'm currently typing on the KB right now! I'll give it a few days and, if everything's still working, I'll post some pics.

Post Reply

Return to “Workshop”