XT/AT/PS2/Terminal to USB Converter with NKRO

User avatar
Muirium
µ

04 Aug 2022, 20:45

apastuszak wrote:
04 Aug 2022, 17:18
I'm having a really odd problem with my Soarer's Converter today.

It's working just fine when I plug it into my Mac. When I plug it into my Windows 10 work computer, it gives me all sorts of issues. It fails to type sometimes. Other times, I will type a letter and will just continuously repeat. I hit backspace and it won't backspace. I hit it again, and backspace runs till I deletes my entire line.

I don't have another Windows computer in the house to test it with, so it's tough to tell if it's something to do with the the Windows 10 image on my work PC, or if it's a problem with the converter and Windows 10 in general.

Has anyone seen this with Windows 10?
Are you using a USB hub?

apastuszak

05 Aug 2022, 02:44

USB switch box.

apastuszak

05 Aug 2022, 17:48

Ok, I think the problem is with the keyboard. It's a Unicomp M122 from 2008. I pulled out my 1985 Model M and plugged in my SDL Soarer's Converter and don't seem to be having any issues, other than really wanting Windows keys.

I'm really tempted to order a PS/2 New Model M and see what happens.

apastuszak

06 Aug 2022, 02:42

Ok. finally figured it out and thought I would share with the group in case someone else has this problem.

So, my old laptop was a ThinkPad T470. Worked great. I had it plugged into a Lenovo USB-C Gen 2 dock.

Then I got uprgaded to a ThinkPad T14 Gen 2. And that's when the trouble started. I compiled a list of driver I wanted updated.

Then I did some experimenting. Rather plugging the Soarer's Converter into the dock, plugged it into the laptop, which was a huge PITA, because it was buried under a bunch of crap.

Talking to my boss about this, he told me I had the USB-C dock plugged into the wrong port on the laptop. On the T470, there was only one USB-C port. On the T14, I plugged it into the same USB-C port. But it turns out there is a thunderbolt 4 port in front of it that I am supposed to use. I plugged the dock in there, and the keyboard has been working OK for the last 5 minutes. If it acts up again, I will report it didn't fix it, and move on with day.

This is obviously a "me" issue and not a problem with the Soarer's Converter.

apastuszak

06 Aug 2022, 02:44

Welp, that didn't fix it.

User avatar
hellothere

10 Aug 2022, 23:45

Assuming that the Unicomp you currently have has a PS/2 connector, have you tried with an PS/2 to USB active adapter? However, this might be a fix as or more expensive than buying parts to build another Soarer's.

I have seen the problem you're having if the ground isn't connected. You might want to check your wiring.

Possibly a firmware issue? I haven't played with Soarer or other converter firmware.

I found out, yesterday, that Drakware has a PS/2 to USB adapter which, I assume, is either based on Soarer's or TMK. They're $25 and I bought the last one yesterday (got a message saying "sold out" when I tried to add another to my shopping cart, so literally, the last one). I've not tried the PS/2 to USB before, but I have used several ADB to USB and I was very happy with them. In other words, you might want to buy one of these instead of building another adapter.

User avatar
Muirium
µ

10 Aug 2022, 23:52

Drakware is neither Soarer nor TMK based, as I understand. They have their own software here:

https://www.drakware.com/firmware

I’ve never bought one. Prefer people and projects who are active in the community.

Post Reply

Return to “Workshop”