Model M issues (some keys not working)


04 Jul 2019, 21:10

Warning! this turned out to be a lengthy post.
Awhile back I got my hands on a model M 1391401 & dated Sep 89', my first proper 'old' mech keyboard. It didn't have a cable but it was still relatively cheap.
I ordered the SDL to USB cable from ebay and when it arrived & I plugged it in I found out that this keyboard might have a slew of issues... and might be possessed.

Here's my KeyTest result(of course no win/menu keys):

So besides the ENTIRE left side of the keyboard not working, both shifts don't work and also the keypad multiply & minus keys aren't working. Beyond the key issues, all three of the lock-lights aren't also working, however they do toggle on and off except for the capslock.

Here's another weird thing about the keys: there's actually ghosting. I've searched far & wide and have never seen any ghosting issues with any model Ms, but this one has some... also with the non-working keys no less. here's a list of what I could find:

Code: Select all

F2 + F4 + F5 = F9
F3 + F4 + F5 = Backspace
F3 + F4 + F6 = ]
2 + 4 = V
W + R = V
S + F = V
and probably more, but that's all I could find atm
I've cleaned the keycaps, all the springs are fine and they all sound and feel the same which makes me assume that the switches are okay and the issue is within the circuitry.

So I opened the board, with hopes that the ribbon plug might be the issue as it seems to be a common problem and an easy fix, but it all looked fine. Here's a dump of pics,
I notice the part number on the metal plate doesn't match the part number on the backplate, is that normal?
Here are some of my ideas:
  • Can the cable be the issue? this is the cable that I got: ... 3062450516 There have been no compatibility issues with it or any complaints, possibly I got a faulty cable? he does mention he tests every cable so I'm doubtful this is the issue. I have also tried plugging in different USB ports with the same result.
  • I think the next logical step would be to open up the metal & barrel plate and check the membranes, of which I'm worried of doing. I'm not even sure what I'd be looking for if I'd open it up. I do have the tools but I don't have the hardware or the experience of doing so and I don't wanna ruin the barrel plate. I'd also have to reuse the membranes as I no longer have the means of buying any replacement membrane sheets.
  • One thing I noticed is that the broken keys seem to be on the same 4 rows, as opposed to being random keys. This makes me think that it might not be water damage, but rather lines on the circuit.
  • is there a possibility that it's the controller module? I honestly don't know what to look for. It just looks like none of the connections are wearing out, none of the electric-y looking bits look like they're burned or blown up.
I guess I've posted here in hopes the experts & model M whiz might be able to help and give guidance. At this point with all these issues, this thing might as well be a parts keyboard, but model Ms are rare where I'm at and I really want to fix it and get it running :(

Apologies for the lengthy post, I just wanted to be thorough & include as many details as I can. Any advice/help appreciated!


06 Jul 2019, 05:42

Sounds like it's time to open it up and see what the rivets look like.


07 Jul 2019, 23:04

Sounds to be like your membranes are dirty and broken - time to open it up!

User avatar

10 Jul 2019, 03:13

Before even opening the assembly, try cleaning the oxidation from the membrane contacts that go into the controller. Gentle rubbing (along the length of the contacts) with a pencil eraser should work.

Post Reply

Return to “Keyboards”