Niz Plum87 - off-center keypress not registering (EC calibration)

Tritian

04 May 2020, 00:36

TL;DR: I have trouble registering off-center key presses on my Niz Plum. The CalibrationLite tool fixes the issue, but only temporarilly. I have to use the Calibration Tool and reset to "InitialCalib" about once a day.

Got my Niz Plum 87 about a month ago. It has become my primary while I gather up the courage to bolt mod my Model M. (any day now...)

This keyboard uses a Topre cloned EC switch and I really like them - although I havent used real Topre yet and I might better like a 55g version than this 45g version - not sure. I wish the tactile experience was a bit more pronounced, with perhaps a reduced event duration.

Anyway - sorry, my issue is this:

Yesterday I noticed my "A" and "D" keys were having trouble registering off-center actuations. I was freaking out. Then I remembered Chyros had a video where he was talking about the need to calibrate his capacitive keyboard for the exact voltage - i think this was for a beamspring though... anyway...

I searched for a Niz Plum calibration tool and after searching through some Engrish and battling 404 errors, I found one:
https://drive.google.com/drive/folders/ ... gKxznoY4aY

This tool works and fixed my A&D keys right up. However today I noticed the D key acting up again! So I used the tool again and it fixed it again. But now I'm concerned... seems the keyboard tends to float off it's defaults for certain keys? wtf?

Any ideas?

Image

Tritian

04 May 2020, 08:32

Just updated the keyboard's firmware using the "X87EC(S)BLE PROGRAMMING SOFTWARE", maybe that will solve this problem for good. There was a new firmware released last month...



update: firmware update sems to have fixed it

DCish

16 Jun 2020, 20:38

I'm having the same problem, I think. Out of the box my J key would sometimes not register (maybe once every 15-20 minutes). I just switched to a 50-gram set of domes, which are great, but now the E key is not registering on every 2nd or 4th press -- like you were, I am freaking out. I love this board and don't want to give it up!

Anyway, I couldn't get either of the things you mention to work. Is the firmware update still working? If so, any chance you could give a few more tips on the installation? I downloaded this file "X87EC(S)BLe_V1.0.21_20200311.bin" from the link you provided above, but it says that there is no program associated with it to run it. Any tips would be much appreciated!

Post Reply

Return to “Keyboards”