Weytec HK2000 with big problem


08 Sep 2020, 20:49

Hello guys, I have one big problem with my Weytec HK2000. This keyboard requires a connector box with mini centronics cable and a power supply for said box which I don't have. My question is now if I somehow could atleast test this unit. Afaik Chyros has this exact switch box that I need to test this unit. And I don't have a manual on how to operate this machine.

What I like about the keyboard:
  • The huge size
    The "Nothing" key
    The ability to program certain keys
    The screen
What I don't like about the keyboard:
  • The requirement of a propriety connector box
    The ability to password protect this keyboard (and make it unusable)
Pictures and brochure: https://drive.google.com/drive/folders/ ... sp=sharing

User avatar

15 Sep 2020, 08:18

These controllers are VERY hard to find on their own, I had to buy a whole second keyboard with the controller box just to be able to use my MK06, took nearly a year to get one for a good price too. If your pockets are deep, you can still get them new through Wey themselves, but expect to pay a few hundred :(


15 Sep 2020, 16:41

I have the previous version, the HK96 and even though i have been able to power on and check that the keyboard should function getting it to work over ps/2 is my difficulty though i do accept that it could be the settings on the keyboard that are wrong however as there is no documentation for these older pre usb varients it is hard to get them setup corrrectly.

Actually looking at the date on the back sticker your board was made 5 weeks after mine so i guess they just changed the model name from HK96 to HK2000


18 Sep 2020, 11:37

Anakey wrote:
15 Sep 2020, 16:41
getting it to work over ps/2 is my difficulty
Do you use windows 10?

I know that in windows 10 you have to enable the ps/2 system driver on system start called "i8042prt.sys - i8042 Keyboard and PS/2 Mouse Port Driver" and reboot your system once, before you can actually use the ps/2 port.


18 Sep 2020, 17:23

Hi, thank you for informinng me that i needed to enable the ports, i have done so in regedit and have restarted pc several times yet the weytec is still not able to fully communicate with the pc over ps/2. i may have not configured the ports properly on the keyboard however the lack of a manual means i can not be sure if i am setting them up correctly.

Post Reply

Return to “Keyboards”