Chicony 5182 not working, can it be fixed?

NeK

23 May 2020, 10:05

So I got my hands on this sweet little Chicony which is in somewhat good condition, but it didn't have any cable. I used a spare that I had that fits it but unfortunately it does not work. Its LEDs are not switching on at all when I connect it.

I am asking those that know about electronics and keyboards: is there a way to determine what part of the pcb is not working and maybe I can repair/fix it and make it work? If not, then I should just harvest its switches and keys and be done with it, or would it worth it to search for a working model and harvest its pcb?

Chicony 5182 - Archie 11.jpg
Chicony 5182 - Archie 11.jpg (628.98 KiB) Viewed 244 times
Chicony 5182 - Archie 12.jpg
Chicony 5182 - Archie 12.jpg (508.8 KiB) Viewed 244 times
Chicony 5182 - Archie 13.jpg
Chicony 5182 - Archie 13.jpg (517.23 KiB) Viewed 244 times

This is the main chip and it has this peculiar pin, maybe this is the cause of the issue or it means something?

Chicony 5182 - Archie 1.jpg
Chicony 5182 - Archie 1.jpg (437.92 KiB) Viewed 244 times

And here are the pictures of the PCB

Chicony 5182 - Archie 2.jpg
Chicony 5182 - Archie 2.jpg (790.36 KiB) Viewed 244 times
Chicony 5182 - Archie 3.jpg
Chicony 5182 - Archie 3.jpg (791.31 KiB) Viewed 244 times
Chicony 5182 - Archie 4.jpg
Chicony 5182 - Archie 4.jpg (705.17 KiB) Viewed 244 times
Chicony 5182 - Archie 5.jpg
Chicony 5182 - Archie 5.jpg (703.76 KiB) Viewed 244 times
Chicony 5182 - Archie 6.jpg
Chicony 5182 - Archie 6.jpg (700.79 KiB) Viewed 244 times
Chicony 5182 - Archie 7.jpg
Chicony 5182 - Archie 7.jpg (741.09 KiB) Viewed 244 times
Chicony 5182 - Archie 8.jpg
Chicony 5182 - Archie 8.jpg (552.49 KiB) Viewed 244 times
Chicony 5182 - Archie 9.jpg
Chicony 5182 - Archie 9.jpg (530.62 KiB) Viewed 244 times
Chicony 5182 - Archie 10.jpg
Chicony 5182 - Archie 10.jpg (685.74 KiB) Viewed 244 times
PS. I got them in higher resolution if anyone needs more detail.

User avatar
purdobol

23 May 2020, 10:59

What's the source of replacement cable? Is it from another 5182?
First thing to check is that the keyboard is actually properly connected.
There's a picture on wiki of 5181, and the pinout goes like this: Clock, Data, Voltage, Ground.

NeK

23 May 2020, 16:46

You are right, the cable was wrong. However, I just tried it with another cable that is cut on the end, I quickly soldered the inside cables one by one with the right order CDVG (and verified each one end-to-end with a multimeter) but it still didn't work.

Maybe the order is not CDVG? I could only verify that the 4th is GND in the PCB. How else can I verify the order on the PCB? As you see in the pictures, there's no markings on them.

User avatar
purdobol

23 May 2020, 17:25

You can search for a data sheet of the closest IC. And check which leg is 5V. Then trace it back to the cable pin.
Then you'll have ground and voltage sorted out. With clock and data pins you can experiment without worrying of damaging anything.

Problem is, the damage could be already done. Wrongly connecting voltage is the best way to fry integrated circuits.

NeK

23 May 2020, 17:42

It is probably fried by now :( I did found the schematic of the IC, it is a variation of the Intel 8049 (https://www.ceibo.com/eng/datasheets/In ... cc-dip.pdf). I have no idea how to check if it is fried. What I verified was that when connected properly the voltages that pass through the IC are 10 volts (checked the Vcc to GND and to VDD pins). Whatever that means.

So you suggest that if something is fried, is probably the IC, am I correct?

Oh well, at least a lesson learned.

User avatar
purdobol

23 May 2020, 17:53

Don't give up that easily :)
Search for the datasheet of the other IC (the one closest to cable) and figure out where the voltage goes.
If you have the datasheet of the main IC check the leg that's bent. What's it for?

After that connect the board properly and check voltages on both ICs. If there's voltage within specified accepted range on both them fidle with clock and data wires. If the board still doesn't work then something is fried.
In that case teensy as a controller to the rescue.

NeK

23 May 2020, 18:31

Ok Ill do that, but I don't want to spent a lot of time on this, so no teensy for me
I will probably harvest the switches and keys and put them on another board. The switches are in good condition and they are early lubed white pines, effectively as good as blue skcm.

I just like this board for some reason, it is heavy, nice looking and feels good. and it is a shame to give it up.

NeK

23 May 2020, 20:19

ok so I traced the first IC (which is hex inverter) to the V and it supplies ~4.9 Volt DC. The second IC which is the microcontroller 8049 chicony version, it gets ~4.9 volt in its Vcc pin, all other pins of the microcontroller, get either 0, 0.3, 4.5 to 4.9 and the GND gets ~0.65. I have no idea what all these mean.

BTW the 'bent' pin is the GND (the one that gets ~0.65 v), and it is not bent, it is in fact an extra connector which is soldered on to the pin and it connects to a hole about half centimeter north that leads to the back pcb. Again, no idea why. Never seen anything like that.

I'l out of ideas on what to do next.

User avatar
purdobol

23 May 2020, 20:32

Ok so both ICs have proper voltage which is a good sign.
Did you connect the clock and data lines to check the keyboard (in either configuration)?
I presume the XT/AT switch is set properly to AT :)

NeK

Yesterday, 12:41

I changed the order of the data and clock, but still nothing. And yes, the A/X switch is at the A(TX) position. :)

I also checked a yet another IC that was behind the keyboard plate but I could figure out the pins from the back of the pcb. It also read ~4.9 V on some of its pins. Also as I was reading the main IC controller, and while I pressed some keys, the readings were suddenly changing, so there is something working at least. But anyhow, I couldn't make it work.

I noted that I tried to read the volt from the A/X switch pins, but it was always 0. The switch supposedly connects the 2 pins at the ATX position and they should have volts coming through, correct? Why is this not happening?

One more idea about the cause that I had is: is it possible that my PS2 to USB (active) converter is not compatible with this pcb?

User avatar
purdobol

Yesterday, 13:31

At this point it's going to be hard to pinpoint what's wrong with the board.
Still think that main IC got fried or at least some part of it. And testing ICs is beyond my capabilities and knowledge. I guess one way of checking it would be seeing what's the output in logic analyzer. But again I'm to stupid for that kind of stuff ;)

As for A/X switch. Most likely it's one time check during bootup sequence.
And if PS2 adapter works on other boards I don't see why it wouldn't on this one.

Sorry I couldn't be of more help.

NeK

Yesterday, 14:35

You've been a great help, despite that we didn't succeed to make it work. Thanks.

Post Reply

Return to “Workshop”