Need help programming some Tipro keypads


25 Nov 2019, 21:13

I picked up two Tipro keypads a while ago and just got together all the stuff needed to program them... or so I thought. They're two of the same type - MID-KM032MAA. I made a cable to connect them following this wiki page, and have that plugged into the PS/2 port of a computer running Windows XP 32-bit. When I plug a keypad in with the computer off(I've only tried one so far since they're the same type), all the lights come on. When I start up the ChangeMe software, it doesn't detect anything plugged into the PS/2 port. The keypad doesn't seem to send any output to Windows either, but it does send scancodes under Linux. The only response I've gotten under XP is a high-pitched beep it emitted when I pressed some buttons while it was scanning (maybe just a rollover warning).

So has anyone got any ideas to try to get these things to cooperate? Do I need some specific version of the software? Do I need a genuine Tipro cable? Do I need the older MIDWIN software? Any help would be greatly appreciated.

User avatar

25 Nov 2019, 23:54

I never had much luck with my ps/2 Tipro MID series. ChangeMe saw it, sometimes, after a long scan as I recall. But the software was very grumpy to do much with it, and crash happy. And all this was at a friend's, to use 32 bit Windows from another era! A whole lot of bother.


26 Nov 2019, 23:59

Well, I'm not there yet, but I've got some progress. Turns out the reason the keypad wasn't sending anything on XP was because ChangeMe deactivates the connection or something. At startup, it works ok. I tried MIDWIN (only needed disk1 to install so I didn't need to get hold of a blank floppy) and that actually recognises it! Selecting "Upload" loads the correct layout and key mappings to the editor. Nice to see something at least realizes the device is there and can understand it.

Unfortunately, selecting "Verify" or "Download" gives a message like "Invalid firmware or MID not connected". Also, the input to set the code for a key only accepts input from the keypad itself (Even a keyboard connected to its PS/2 port does nothing). Pretty limiting in what can be input as you can imagine!

Still looking for any knowledge at all that might help here.

User avatar
The Tiproman

27 Nov 2019, 07:12

I might be able to help here,
but sadly I'm not sure it will be a great help.

Usually Tipro 8x4 keypads are just extensions for bigger Tipro boards
and as such do not have a controller of their own and are not programmable separately.
And 8x4 keypads with a controller are extremely rare.

So that's the first thing you'd have to check.
The controller would be a small PCB sitting on top of the matrix PCB.
Alternatively, if the keypad has just one PS/2 socket, it will have no controller.

Edit: sadly controllers for bigger units are too big to fit a 8x4 unit,
but Tipros are known for their versatility
and the Tiproman for almost magical resources :mrgreen:


28 Nov 2019, 22:49

Programming the PS/2 Tipros is a bit of a pain,I documented the method I used in my first post here- viewtopic.php?f=2&t=18949 , it's annoying but it works,I keep an old mini itx box with 32 bit Win 10 on it for when I need to redo mine.


01 Feb 2020, 00:57

I've been giving this another look. Thanks everyone for all the info in this thread before. I've been keeping an eye out for a larger MID device which might help get these keypads up and running, and this kind of thing looks promising. I'm wondering though, do all larger Tipro units have a controller module or are there some that also rely on a different unit for programming, the same way as these small ones? Does anyone know about this? I notice that this one on eBay has a fair few blanked holes where sockets could have gone. It just has the one PS/2 and one Tipro socket like on the 32-key units. I'm wondering if that means anything about what functionality it does or doesn't have.

Post Reply

Return to “Workshop”