SOLVED: Help With Soarer's Converter


15 Sep 2021, 18:23

Hi Everyone,
I am working on building a Soarer's converter for my Model F XT using a Dfrobot Beetle which is basically a compact version of an Arduino Leonardo. The problem is that I have not been able to successfully flash the code using command prompt. I tried two different ways but both just get stuck on connecting to programmer as you can see in the screenshots. It is worth noting that command prompt is finding the microcontroller because when I unplug it the process fails. Any help is much appreciated because I really want to get this keyboard working :)

Edit: I got it working! The problem was that when I put my microcontroller into bootloader mode it temporarily changes the COM port so I had to flash to that port instead.
Screenshot (191).png
Screenshot (191).png (44.46 KiB) Viewed 373 times
Screenshot (188).png
Screenshot (188).png (14.56 KiB) Viewed 373 times
Last edited by Barracuda725 on 15 Sep 2021, 23:10, edited 1 time in total.

User avatar

15 Sep 2021, 19:50

Hmm. When it comes to flashing, I always use QMK Toolbox:

It has a bunch of these utilities under the hood. Even command line averse rubes like me can usually make it work. (Always, actually. But I’ve not tried this particular case.)

Post Reply

Return to “Keyboards”